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This document provides a “quick start” explanation of how to use 
Aperio’s Release 6 ImageScope software to view digital slides. 
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IMAGESCOPE INSTALLATION AND QUICK START GUIDE 
 
This document provides a “quick start” explanation of how to use Aperio’s 
Release 6 ImageScope software to view digital slides.  

RUNNING IMAGESCOPE 
• First you must install ImageScope on your computer.  After clicking on the 

“Get Aperio ImageScope” button and saving the ImageScope.exe installer 
program to your hard disk, navigate to where you saved the file and double 
click on the installer program (ImageScope.exe). 

o Select Next/Finish options on any displayed screens as required to 
install ImageScope. 

• Now you are ready to use ImageScope.   
o To open digital slide files on the web (e.g., files found in Aperio’s 

Digital Slide Gallery), click the “Open with ImageScope” link on the 
web page. ImageScope will automatically launch and open the file. 

o Launch ImageScope manually from the Start>Programs>ScanScope 
menu, and then open a digital slide image by selecting Open Local 
from ImageScope’s File menu.   

• Once a digital slide is selected for viewing, ImageScope opens/supports 
various windows and dialog boxes – described below: 

THE MAIN WINDOW 
• This window displays a portion of the selected slide at its full resolution. 
• You can easily pan by grabbing the Main Window (press the left mouse 

button and hold down - mouse cursor changes to a fist) and moving it in any 
direction. 

• You can scroll by moving the mouse towards an edge of the window (mouse 
cursor changes to an arrow) and holding down the left mouse button. 

• You can enter joy-stick mode by double clicking the right mouse button while 
in the Main Window (mouse cursor changes to a diamond-in-square shape).  
The image will automatically pan in the direction you move the mouse (once 
in joy-stick mode, press either mouse button to leave the mode).  

• You can click on the back button (toolbar’s left green arrow) to return you to 
a previous view of the digital slide.  Clicking on the forward (right arrow) 
retraces the views.  Just like a web browser! 

THE THUMBNAIL WINDOW 
• This window is accessed via the toolbar’s “picture” button (just to the right of 

the “magnifying glass” button).  It may or may not be displayed according to 
whether or not it was “open” when ImageScope was last closed.  

• When open, it is displayed in the upper right corner, and contains a 
thumbnail view of the entire slide.  A black rectangle that represents the 
portion of the image that is currently displayed in the Main Window.  

• You can quickly navigate to any location on the digital slide, as displayed in 
the Main Window, by clicking the desired location in the Thumbnail Window, 
or by dragging the black rectangle to the desired position.  

• The Thumbnail Window can be resized by dragging its lower left corner. 
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THE ZOOM TOOLS 
• This tool window is displayed in the upper left corner, and shows the zoom 

level associated with the Main Window’s image.   
• The display resolution of the image shown in the Main Window can be 

changed by clicking on an explicit zoom level, or by clicking and “sliding” the 
associated slider.  In addition, if your mouse supports a mouse-wheel, rolling 
the wheel causes the zoom slider to move up/down to different zoom levels. 

• The size of the black rectangle in the Thumbnail Window changes according 
to changes in the zoom level.  The size increases as you zoom out because 
a larger region of the slide is displayed in the Main Window. 

• Another way to zoom the image is via the zoom button (dotted rectangle 
w/arrow on the toolbar).  First click the zoom button to select it.  Then click in 
the Main Window and hold the left mouse button down to stretch the “zoom 
rectangle” over an area to be zoomed into.  When you “let go” of the mouse 
button, the Main Window will be zoomed to the area you selected.  The 
Thumbnail Window will show the orientation of the area to the full slide, and 
the Zoom Window shows the associated zoom level.  This tool can be used 
successively to “drill down” into an image.  You can use the back button 
(green left arrow on toolbar) to return to the original zoom. 

THE MAGNIFIER WINDOW 
• This window is accessed via the “magnifying glass” button on the toolbar.  It 

may or may not be present according to whether or not it was “open” when 
ImageScope was last closed.  

• When visible, the image displayed in the magnifier window is shown at twice 
the magnification of the image displayed in the Main Window.  The contents 
of the magnifier window correspond to the region under the mouse cursor in 
the main window. 

• The Magnifier Window can be grabbed (press the left mouse button and hold 
in - mouse cursor changes to a fist) and moved to any location in the Main 
Window in order to examine it more closely.   

• The Magnifier Window can be resized by dragging its lower right corner. 

THE ANNOTATIONS WINDOW 
• This window is accessed via the Annotations Window option in the View 

menu.  It may or may not be present according to whether or not it was 
“open/selected” the last time ImageScope was closed.  It is used to describe 
any annotations associated with the image, where these annotations can be 
optionally saved/reloaded according to an xml file associated with the image.   

• Annotations consist of user-defined regions, rulers, and pointers “drawn” on 
the image, and are created using the various annotation tools available on 
the right portion of the tool-bar:  the pen, rectangle, ellipse, ruler, and pointer 
tools.  

• In general, all of these tools work the same way.  Select the desired tool on 
the toolbar, place the mouse cursor (shown as a pen) on the desired starting 
location in the Main Window, and then click and hold in the left mouse button 
while you move the mouse as required to create the annotation (let go when 
you get to the desired ending location).  

• Annotations automatically “scale” according to the zoom level used to 
display the image. 
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• Annotations are stored in “layers”, where an image can have multiple 
annotation layers, and where a given annotation layer can contain multiple 
annotations.   All the annotations of a given layer are “drawn” in the same 
color, and the assigned layer color differs from one layer to another. 

• The annotations defined for a given layer are displayed on the Main Window 
according to the “eye” button state.  (Clicking the eye button toggles whether 
the layer is displayed.) 

• The Annotations Window can be used to create new annotation layers (“+” 
button), to delete annotation layers (“X” button), to assign descriptions to 
annotations, and to assign/modify the colors used for the annotations. 

THE ALGORITHMS WINDOW 
• This window is accessed via the Algorithm Window option in the View menu.  

It may or may not be present according to whether or not it was “open” the 
last time ImageScope was closed.  It is used to perform algorithmic analysis 
on the digital image.  This processing can be performed on the entire slide or 
on selected region(s) of the slide. 

• You use the Algorithms Window’s “Change” button to select the desired 
algorithm.  After selecting an algorithm the system sets the default input 
parameters associated with the algorithm.  You have the ability to update 
those parameters as desired. 

• In the Algorithms Window you select the portion of the digital image on which 
to run the algorithm.  You can select the region currently displayed in the 
Main Window (Current Screen option), the entire image, or the region(s) 
defined on the currently displayed annotation layer. 

• The results of an analysis are displayed in two ways: 1) visually, by 
“marking-up” the selected portion of the image displayed in the Main 
Window, and 2) quantitatively, by automatically creating a new annotation 
layer that contains the results.  Markup image generation is optional and 
selected by a checkbox in the window. 

• You can experiment with analysis processing by opening the Algorithms 
Window and selecting Aperio’s “Positive Pixel Count” algorithm (via the 
“Change” button).  This algorithm demonstrates the analysis capabilities of 
the Aperio system.  Next open the Annotations Window and use the Pen tool 
to draw one or more regions on the “current” annotation layer.  Then select 
“Selected Annotation Layer” in the Algorithm Window, check “Generate 
Markup Image”, and click Run to run the algorithm on the regions defined in 
the annotation layer.  When the analysis is complete, the selected regions of 
the Main Window are enhanced to show the analysis results, and a new 
annotation layer (as seen in the Annotations Window) is created to store the 
markup and quantitative results.   

• You can examine the results by selecting the “last” layer tab in the 
Annotations Window.  Use the “eye” button to toggle the markup results 
on/off in the Main Window.  Additionally, these results can be exported by 
using the “export grid to text file” button (small notebook), for example for 
use with an Excel spreadsheet. 

• Note: there are two pen tools on the toolbar, the one on the left is for drawing 
ordinary annotations, while the one on the right (with the dashed line coming 
out of it) is for drawing negative annotations.  Negative annotations are used 
to define regions where analysis processing should be skipped.  For 
example, if this tool is used to draw a small circle inside of a larger circle 
drawn with the regular Pen tool, then analysis would only be performed on 
the area between the two circles (a doughnut shaped region). 
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THE DIGITAL SLIDE CONFERENCING WINDOW 
• This window is accessed via the Digital Slide Conferencing Window option in 

the View menu.  It may or may not be present according to whether or not it 
was “open” the last time ImageScope was closed. 

• You use this window to set up a conference between two or more 
computers.  All of the participants in a conference “see” the same digital 
slide images at the same time (including annotations). 

THE DIGITAL SLIDE INFORMATION DIALOG BOX 
• You can display digital slide information by clicking on the “image 

information” button on the toolbar (blue “i”), which causes the Image 
Information dialog box to open.  This window contains general information 
about the slide, an image of the slide’s label, and the slide’s thumbnail 
image. 

THE IMAGE ADJUSTMENTS DIALOG BOX 
• You can control the displayed image colors by utilizing the various options in 

the image adjustment dialog box - accessible via the Image Adjustment 
button (slider) on the toolbar.  This window contains options to control the 
brightness/contrast and the color balance, and provides a mechanism to 
store/load specific color adjustments. 

VIEWING MULTIPLE DIGITAL SLIDES 
• You can open any number of images in ImageScope and view them side-by-

side.  You can use the tiling options in the Window menu to arrange the 
windows when you have multiple images open.   

• You can use the synchronize button (the “tree-structure” button on the 
toolbar) to “sync-up” the display location and magnification level of the 
opened images.  If you select this tool and then pan or zoom in one image, 
any other open images will also be panned to the corresponding location and 
zoomed to the same resolution.  

VIEWING REMOTE SLIDES 
• Aperio has a client/server viewing architecture that enables images stored 

on a remote server to be accessed across a network or the Internet. 
• If you have Internet access, you can attempt to open a slide located on 

Aperio’s image server. 
• Select the Open Remote Image option from the File menu.  
• Select “images2.scanscope.com” for the Server and 80 for Port, and press 

“Connect.” 
• Double-click on the Aperio folder to display a list of available images. 
• Select an image, click the “Open” button, and view the image as described 

above. 
 
 




